Maximum number of loops exceeded!

Das Forum soll der Ablage von Lösungen für immer wieder auftauchende Problemstellungen dienen. // This forum contains solutions to problems that frequently occur.
Antworten
Benutzeravatar
dr.e.
Administrator
Beiträge: 4525
Registriert: 04.11.2007, 16:13:53

Maximum number of loops exceeded!

Beitrag von dr.e. » 22.12.2007, 00:31:06

Tritt während der Entwicklung der Fehler

Code: Alles auswählen

  Fatal error: [xmlParser::getAttributesFromString()] Error while parsing: " href='http://de.php.net/
  manual/de/function.strtr.php'". Maximum number of loops exceeded! in ***\apps\core\pagecontroller\
  pagecontroller.php on line 197


auf, ist folgende Ursache gegeben:

Da im URL-Filtering nun auch der Output der Seite gefiltert und Links ggf. rewritet werden, kann es passieren, dass der Filter-Parser bei HTML-Fehlermeldungen mit einem Fehler beendet wird. Hintergrund ist, dass der Parser nur '"' als Wert-Delimiter erkennt. Abhilfe schafft hier das Deaktivieren von HTML-Fehlermeldungen in der php.ini mit

Code: Alles auswählen

html_errors = Off


oder das Auskommentieren des HTML-Filters im der Klasse Page, Methode transform():

Code: Alles auswählen

979      // Links rewriten, wenn erwünscht
980      if($this->__URLRewrite == true){
981         $hURF = filterFactory::getFilter('core::filter','htmlLinkRewriteFilter');
981     --> //$Content = $hURF->filter($Content);
983       // end if
984      } 
Viele Grüße,
Christian

Benutzeravatar
dr.e.
Administrator
Beiträge: 4525
Registriert: 04.11.2007, 16:13:53

Re: Maximum number of loops exceeded!

Beitrag von dr.e. » 10.01.2009, 12:56:05

Ergänzung:
Seit dem 1.9er Branch kann der OutputFilter einfach über die Registry deaktiviert werden. Dies kann in der index.php wie folgt erledigt werden:

Code: Alles auswählen

$reg = &Singleton::getInstance('Registry');
$reg->register('apf::core::filter','OutputFilter',null);
Viele Grüße,
Christian

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast