konfigurationsprobleme bei der version 1.9

Alle Fragen zur Installation und zu den erhältlichen Versionen sind hier an der richtigen Adresse. // All questions on installing the APF.
Antworten
disasterarea
Beiträge: 4
Registriert: 22.03.2009, 21:39:44

konfigurationsprobleme bei der version 1.9

Beitrag von disasterarea » 22.03.2009, 21:54:36

hallo,

da ich mit dem framework gerne arbeiten möchte hab ich den code runtergeladen und die 1.8 version auch schon ausprobiert - angefangen bei den
beispielen und diese auch entspr. meinen vorstellungen erweitert.

jetzt habe ich mir heute die 1.9' er version runtergeladen.
leider scheitere ich dort schon an der konfiguration der default_pager.ini.

ich bekomme die meldung:
[connectionManager::getConnection()] The connection type may not be equal to "MySQL". Please check the connection configuration at the "MySQL" section!
wo der fehler liegt ist mir klar, nur leider nicht, wie ich ihn beheben kann.
ich hab unter Pager.DatabaseConnection diverse einstellungen ausprobiert, vielleicht auch nur ein sonntagsbrett vor dem kopf.

für hilfe wäre ich sehr dankbar.

schöne grüße,
marcus

Benutzeravatar
dr.e.
Administrator
Beiträge: 4538
Registriert: 04.11.2007, 16:13:53

Re: konfigurationsprobleme bei der version 1.9

Beitrag von dr.e. » 22.03.2009, 22:31:02

Hallo Marcus,
ich bekomme die meldung: [connectionManager::getConnection()] The connection type may not be equal to "MySQL". Please check the connection configuration at the "MySQL" section! wo der fehler liegt ist mir klar, nur leider nicht, wie ich ihn beheben kann. ich hab unter Pager.DatabaseConnection diverse einstellungen ausprobiert, vielleicht auch nur ein sonntagsbrett vor dem kopf.
Der Grund ist recht einfach: die Konfigurationssektion "MySQL" darf in der Direktive "DB.Type" kein "MySQL" enthalten. Nutzt du den MySQL-Treiber, der im Framework enthalten ist, muss dort "MySQLx" vermerkt sein. Details kannst du unter http://adventure-php-framework.org/Seit ... rschichten nachlesen.

Zum Hintergrund:
In der Version 1.9 wurde der Pager einem Refactoring unterzogen. Dies beinhaltete die Umstellung auf den ConnectionManager als Datenbank-Abstraktionsschicht. Details zur Migration von Cersion 1.8 auf Version 1.9 findest du unter http://adventure-php-framework.org/Seit ... ngen-Pager.

In deinem konkreten Fall wird der Fehler deshalb ausgegeben, da die Sektion, die die Datenbankverbindung konfiguriert als DB.Type "MySQL" enthält. Erlaubt ist jedoch nur "MySQLx". Dies hat den Grund, dass der MySQLHandler veraltet ist und nicht mit dem ConnectionManager verwendet werden kann.
da ich mit dem framework gerne arbeiten möchte hab ich den code runtergeladen und die 1.8 version auch schon ausprobiert - angefangen bei den beispielen und diese auch entspr. meinen vorstellungen erweitert.
Solltest du dabei noch Anregungen benötigen, melde dich einfach. :)

Viele Grüße,
Christian
Viele Grüße,
Christian

disasterarea
Beiträge: 4
Registriert: 22.03.2009, 21:39:44

Re: konfigurationsprobleme bei der version 1.9

Beitrag von disasterarea » 23.03.2009, 15:49:32

hallo christian,

danke für deine schnelle hilfe. wer lesen kann ist eindeutig im vorteil, ich hab mir zwar die konfigurationssektion gestern durchgeschaut, aber die stelle an der mysqlx steht (und zwar eindeutig) übersehen. lag wohl doch am sonntag...

aber mit der konfiguration hab ich trotzdem noch so meine probleme, die ich teilweise in der 1.8 er version gelöst hatte.
z.b wird das captcha beim kontakt formular und beim comment modul nicht angezeigt.

aber ich werd mir erstmal die doku noch genauer durchlesen...das hilft.

also, danke nochmals und viele grüße.
marcus

Benutzeravatar
dr.e.
Administrator
Beiträge: 4538
Registriert: 04.11.2007, 16:13:53

Re: konfigurationsprobleme bei der version 1.9

Beitrag von dr.e. » 23.03.2009, 23:02:10

Hallo Marcus,
aber mit der konfiguration hab ich trotzdem noch so meine probleme, die ich teilweise in der 1.8 er version gelöst hatte.
z.b wird das captcha beim kontakt formular und beim comment modul nicht angezeigt.
Welche Probleme? Vielleicht kann ich diese gleich am Anfang aus dem Weg räumen, damit du dich leichter tust ...

Viele Grüße,
Christian
Viele Grüße,
Christian

disasterarea
Beiträge: 4
Registriert: 22.03.2009, 21:39:44

Re: konfigurationsprobleme bei der version 1.9

Beitrag von disasterarea » 24.03.2009, 16:57:03

hallo christian,

habe die konfiguration inzwischen komplett hinbekommen, aber danke für dein angebot.

ich hab mir einfach mal ne stunde zeit genommen und alle module konzentriert entsprechend der
beispielkonfiguration eingerichtet, das hat schon gereicht.
läuft alles super (ist ja auch super beschrieben, man muß nur genau hinschauen).

ich werde nun mal eine seite aufsetzen, bzw. ein bisschen testen.
wenn ich fragen oder anregungen habe werde ich mich wieder melden.

danke und schöne grüße,
marcus

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast